Wrong / different images than in store manager compared to live site

Wrong / different images than in store manager compared to live site

Avatar image
Jan 29, 2014
Dale Buird wrote
I did use bulk csv upload to create these products

But I am very confused on why this happening! As you can the correct image is associated with the item but for some reason a womens top form another listing is showing on the live site??? And this is just one example. Most imported the correct images but this issue isnt just for one product but many.

http://prntscr.com/2np3ci

http://prntscr.com/2np3pt

And yes I have posted data to web: http://prntscr.com/2nptke
Reply
6 Answers
Avatar image
Jan 30, 2014
Andrii Yanosh agent wrote
Hello Dale,

It looks like image upload process has been interrupted (probably temporary FTP connection issues) and some product image resizes have been corrupted while update.

The Store Manager displays the main product images, which have been uploaded correctly.
In case there is just a few incorrect images, you can replace them manually. As an option you can re-import products once more in order to regenerate product images.
Avatar image
Jan 30, 2014
Dale Buird wrote
yeah I deleted everything and re uploaded and it helped . still a couple images that ported over but 95% were good versus 50%
Avatar image
Feb 27, 2014
Ron wrote
We get this problem quite frequently. I think it is to do with multi-shop and multiple installations

We access three stores (not multishop) within store manager. When we switch from one store to another, if there are any ftp tasks that have stopped for any reason they stay in the cache That means the ftp data (username and password) stays set for the old store rather than the new store just switched to. So when you try to look at images in the new store, the system is still looking at the old store

Does that make sense?

So when we are needing to work with images the first thing we do is switch to ftp tasks queue and delete any thing there. This clears the cache, store manager then pics up the correct ftp details and all is well

Bit of a pain, but workable

So ideally store manager should clear out the ftp queue whenever you switch between stores
Avatar image
Feb 28, 2014
Andrii Yanosh agent wrote
Hello Ron,

The Store Manager does not wipes out the FTP tasks queue when you switch between connections. Otherwise if you switch to another store after any import procedure, all image upload tasks for your previous store will be deleted and the images will not be uploaded accordingly.

You should try to decrease the Max FTP Threads in Preferences(F12) > FTP tab.
That will slow down the upload process, however it will be more stable.

If the issue remains, please submit a ticket: http://support.emagicone.com/submit_ticket
Avatar image
Mar 01, 2014
Ron wrote
I understand why the queue can;t be cleared, but i think this is to do with stopped processes so increasing Max FTp will not make a difference (will try it though)

I think it is when Store Manager expects an image and does not find one. For example, not all our categories have images associated with them. When I click on that categry, store manager tries to get the image but it is not there so the process is stopped

When I switch to another store, that stopped process is still in the queue and that prevents store manager from changing the ftp details and therefore it can;t get the correct images for the new store

As I said it is not something that causes us many problems now I know what it is but thought it may shed some light for others
Avatar image
Mar 03, 2014
Andrii Yanosh agent wrote
Hello Ron,

Thank you for your post.

Yes, the Store Manager collects all tasks in the FTP Queue (for 1 session), even those ones that have been stopped due to various reasons, just in case they have to be double checked.