"You have a problem with your database"

"You have a problem with your database"

Avatar image
Jul 19, 2013
David González wrote
After performing a product import, both me and my workmate (with different Store Manager licences, but editing the same Prestashop database) get this behaviour when opening the program independently:

1) We launch Store Manager and it starts connecting with the database with no problems.

2) We get this message: "You have a problem with your database. Please check all the tables available in your database or check database configuration".

3) No matter if we open and review preferences, or close the program (it doesn't close, by the way). Store Manager connects gracefully with the database, opens and shows data as usual. Everything seems to be OK in Store Manager: categories, products, features, attributes... everything! Prestashop's backoffice also shows everything normally.

4) However, since this misterioues error dialog first appeared in Store Manager, no categories or products are shown in Prestashop's frontoffice. Not in the menus and not even in the webmap page. Direct URLs to categories do not work either. Products are not accesible and direct URLs seem not work anymore. Search does not deliver any result.

I have tried the following:
- Repair all tables in phpMyAdmin
- Reindexed everything (both with Store Manager and Prestashop backoffice)
- Reinstalled and updated template
- Reinstalled and reconfigured top menu (with categories links)
- Installed an alternate top menu (Mega Menu)
- Reinstalled and rehooked blockcategories module

No results at all. Why is Store Manager showing that error and what does it exactly mean? Any suggestions? Thank you!

Reply
13 Answers
Avatar image
Jul 19, 2013
David González wrote
By the way, the website under construction is http://www.perfumeriaeuropa.com/shop .
Avatar image
Jul 19, 2013
David González wrote
I have also cleared cache and rebuilt Categories NTree. No results. I also activated SQL LOG writing in the advanced settings, relaunched Store Manager and got the error. Maybe the log could give me a clue on what's going on. However, I can't figure out WHERE is this log file located. No information on this on the documentation or the forum. I have not located any suitable log file in my hard disk. Could you clarify this, please? Thank you!
Avatar image
Jul 22, 2013
Andrii Yanosh agent wrote
Hello David,

Thank you for your posts.

The issue you have faced is quite untypical. Please submit a ticket here: http://support.emagicone.com/submit_ticket and provide us with your store configuration file, so we could check it from our side and advise you on this regard.

*You can save you store configuration file at: Store Manager > Preferences(F12) > Database Connection tab > Store Configuration section > Actions... > Save current configuration: screencast.com/t/Hmy0nUDBsHJc
Avatar image
Nov 04, 2013
Guillermo Sandoval wrote
Same problem here. How did you solve it?
Avatar image
Nov 05, 2013
Andrii Yanosh agent wrote
Hello Guillermo.

Please submit a ticket and provide us with your store configuration, so we could check it from our side.
Avatar image
Jun 16, 2014
Odeen wrote
\AppData\Local\eMagicOne Store Manager for PrestaShop\LocalMySQLData\data

i deleted bridged data and renewed..

and

done - everything working again :)
Avatar image
Dec 21, 2018
Andrew Kumar wrote
I'm having this issue in 2018.
Mar 10, 2019
User wrote
Confirm problem exists. It happened afer update from 1.7.3.2 to 1.7.5.1 with bridgeconnector 1.19 when I tried to get data from the web.
deleting everything at \AppData\Local\eMagicOne Store Manager for PrestaShop\LocalMySQLData\data\*.* resolved the issue.

Dear Developers add to your manager big red button - "delete all local data". Also it's reasonable to delete all related local data when connection is deleted.
Avatar image
Mar 11, 2019
Olha Berestetka agent wrote
Hello David!
thank you for your suggestion!
We will consider it for future releases!
Thank you and have a good day!
Apr 24, 2019
constanza wrote
I deleted all data and i was able to open the program, but i cont see products, if i press get data from web, i get the error again.

helppppp happened when updated from 1.6 to 1.7.5.1
Avatar image
Apr 25, 2019
Olha Berestetka agent wrote
Hello,

thank you for letting us know.

Please make sure you are using the latest store manager version for PrestaShop, where support for PrestaShop 1.7.5.1 was added.

In case the issue still remains contact us by email: contact@emagicone.com, so it will be taken into the deeper investigation.
Jun 23 (33 days ago)
Atlihan Dundar wrote
I ran web import. I have the same problem, what should I do?
23.06.2021
Avatar image
Jun 24 (32 days ago)
Nadia Bezpalko agent wrote
Thanks for your post. Did you try to do the following:

1. Close the Store Manager
2. Please try to delete the folder on your PC with your %database name% in "LocalMySQLData" folder
You can find this folder on your PC by this path : - c:\Users\%username%\appData\Local\eMagicOne Store Manager for Prestashop\LocalMySQLData\data\%database name% (check your Database name in Store Manager's Preferences) https://www.screencast.com/t/yZDlKApVqPO
3. Open Store Manager again
4. Get data from web(Ctrl+G)