url for item in menu after categories import are full path

url for item in menu after categories import are full path

Avatar image
Apr 22, 2016
Keyur Shah wrote
When I manually create a category through the web interface or through the store manager, the links in the top nav menu for the frontend shows the proper url, i.e.,

/widget.html

but when I create the categories through the import feature, the links in the top nav go to:

/catalog/category/view/s/widget/id/6/

i've tried playing with the url rewrites, but no luck.

thanks!
Reply
7 Answers
Avatar image
Apr 25, 2016
Support Manager agent wrote
Hello,

Thank you for your post

Please clarify what Magento version do you use from your side?
Also, please submit a ticket with your store connection configuration (you can save it at Preferences[F12] / Actions / Save current configuration), import configuration (you can save it at the last step of import wizard - http://screencast.com/t/859soIifs ), .csv file and admin access to your store, so we could check what caused the issue for you.

Waiting to hear from you
Avatar image
Apr 25, 2016
Keyur Shah wrote
ok, I will put that together as I get a chance. Thanks.
Avatar image
Apr 26, 2016
Support Manager agent wrote
Hello

Thank you for your reply

We are looking forward for details from you
Aug 09, 2017
Ajit wrote
Hello - is there any other way than resaving the category or product?
Avatar image
Aug 10, 2017
Yana Kostyk agent wrote
Please specify your question with some examples or provide more details as I am not sure that I fully understand it.
Aug 10, 2017
Ajit wrote
Even though the database has
testing.html as redirect to catalog/category/view/s/testing/id/7/

it does not show up as http://domain.com/testing.html until I go into store manager doubleclick on category to open it - do nothing but save it by saying OK.
Once that is done and I refresh cache the category now shows as http://domain.com/testing.html

I was wondering if there is an easy way to open all categories and resave them - since that is what seems to be required to get it to work.

DOnt know what caused this - but for products it is fine. Probably because when I imported products they were in slightly different categories and I re arranged them.

Thanks
Avatar image
Aug 11, 2017
Yana Kostyk agent wrote
Please submit a ticket here https://support.emagicone.com/submit_ticket so we could check why the category URL issue occurs for you and try to solve it.